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What is the Network File Manager?
Network File Manager (NFM) was developed as an enhancement to traditional ftp-based 
file transfer programs.    The term ftp is a UNIX term referring to a protocol that is used to 
copy files to and from UNIX hosts.    The Network File Manager can be used to transfer files 
between your PC and a local host (a host on your network), or to a remote ftp server on the 
Internet (a system containing publicly accessible files).
SPRY Network File Manager offers sophisticated file transfer between your PC and a remote
host, or between two remote hosts, using an intuitive Windows interface that works side by 
side with your Microsoft Windows File Manager.    Drag and drop files directly from your 
host onto your Windows desktop, and vice versa.
SPRY Network File Manager is enhanced to provide advanced file management functions 
(sorting files by name, type, size, and date; creating, copying and moving directories, etc.), 
using a familiar Windows interface, making host file manipulation quick and intuitive.    NFM 
menu items are similar to those in the Windows File Manager, and buttons are offered to 
simplify repetitive tasks.
Warning: Please note that NFM supports only procedures and file listings that are 

supported on the host you are connected to.

Network File Manager Requirements
> Remote hosts must be setup as FTP servers (be running the ftp daemon) to be accessed by 

Network File Manager. 

> The Microsoft Windows 3.1 File Manager program is required to use the drag and drop file 
transfer capabilities of the Network File Manager.

A command-line based FTP application, FTP Command Line, is also available for those who
are familiar with FTP and prefer a command line interface; see the end of this chapter for 
information.



Starting the Network File Manager
You start the Network File Manager (NFM) by clicking on the NFM icon.    You will see a 
<Connect to>* dialog asking you to login to a host.
Note: If you have NFM set up to automatically reconnect you to each host you were connected to in your last NFM

session, a <Reconnect To> dialog may appear before the <Connect To> dialog.    See NFM Startup Options 
for more information on this reconnect option.

You start the Network File Manager (NFM) by clicking on the Network File Manager icon.    
When you start NFM, it will open your Windows File Manager, and then display a <Connect 
To> dialog, asking you which host you want to connect to.    (If you have enabled the Restore
Connections option, this dialog will be called <Reconnect To>.)
Click Connect To or Reconnect To for information on filling out this dialog.
When you complete the dialog, click OK.    You will start connecting to the FTP server you 
specified.    The Status Bar at the bottom of the NFM Console will display Connecting to 
<hostname>.    If a connection is made, the Network File Manager will bring up a directory 
window displaying the files on that host.
You can immediately begin transferring files; see Working with Files in NFM for information 
on file transfer and other operations.



Connect To
Use the <Connect To> dialog to connect to a remote host's file system.    You connect to a 
host by specifying a Connection name, a host name, and your login user name and 
password.    You can optionally specify advanced connection options by pressing the 
Advanced button.    
You can connect more quickly by selecting a Connection name from the Connection drop 
down list.    This will automatically fill in the host name, user name, password, and all other 
connection information for you.    See Auto Save to Connection List for more information on 
how connections are added to this Connection list.
Choose one of the following options for more information:
Connection
Host
Host Type
User Name
Password
Account
Auto Save to Connection List
________
See Also
Default Connection Information
Edit Connection List



Reconnect To
When you start an NFM session, NFM will attempt to reconnect you to any hosts you were 
connected to in your last session by presenting you with a <Reconnect To> dialog.    This 
dialog will contain the login information you used when you connected to the host.    Click 
Connect To for information on filling out this dialog.
Click OK in the <Reconnect To> dialog to automatically reconnect to that host, or press 
Cancel to reject the reconnection. You will be presented with a separate dialog for each host
you connected to in the last session.      If you cancel all reconnections, you will be presented 
with a blank <Connect To> dialog and you can type in information for a new host you want 
to connect to.
(Alternately, you can simply type new connection information in the <Reconnect To> dialog 
in order to connect to a new host.)
If you prefer not to automatically reconnect to hosts, you can disable this feature using the 
Restore Connections at Startup option in the <Startup Options> dialog.



Connection
Connections can be used to remember your host name, user name, password, and all other 
connection information.    
Type a name for a new Connection, or select an existing Connection from the drop down list. 
If you type a new Connection name and have the Auto Save to Connection option selected, 
the Connection will be added to the Connection list.
Selecting a Connection name from the Connection drop down list will automatically fill in the 
host name, user name, password, and all other connection information.
________

See Also
Edit Connection List



Host:
Specify the address for the ftp host you will be connecting to.    You can specify a host by its 
IP address (such as 165.121.6.65) or its Fully Qualified Domain Name (FQDN) (such as 
mycroft.bakerstreet.com).    Type the IP address or FQDN in the hosts field.
If you have a hosts file on your system, hosts listed in that file will appear in the Hosts: 
drop down list, and you can select hosts from that list.    You may or may not have a hosts 
file on your system, according to your installation.



Host Type:
Host type indicates the file format for the FTP host you are connecting to.    FTP is set up to 
Auto Detect the host type; it will try to detect the file format of the remote host and display 
files accordingly.    In most cases, you should leave the Host Type: field set at Auto Detect.    
If NFM has trouble displaying all the file information for files on the remote host, and you 
know the host type for the remote host, you should select that host type from the list, and 
try reconnecting.    If you are unsure of the host type, and Auto Detect does not work, choose
Generic.



User Name:
Specify your username (login name) on the ftp host you have specified.    
If you are connecting to an anonymous ftp site (a publicly accessible ftp site) on the 
Internet, you will usually be asked to specify a login name of anonymous with your e-mail 
address as your password.(i.e. lucy@narnia.com).



Password:
For Password:, specify your password on the ftp host.    You must specify a password; if 
none is required on the host you are connecting to, type in a few random characters.
As mentioned above, anonymous ftp sites usually require you to supply your e-mail address 
as a password.
Note: If you chose to install a Secure version of NFM during installation, NFM will not save your password 

information.



Account:
Some ftp hosts require an account number.    If this is the case, fill out the account number in
this field; it will be passed to the host.



Auto Save to Connection List
Select this option to have NFM automatically add Connections to the Connection list.    When 
this option is selected, a Connection name is required before you will be able to complete 
the connection.    If this option is selected and you make changes to a Connection already 
defined, those changes will be saved, replacing the old Connection information.
If you do not have this option checked, but specify a new Connection name for your NFM 
session, you will be asked if you want to save the new Connection to the Connection list.    In 
most cases, you will probably want to save Connections, since it makes reconnecting to a 
host easy.



Advanced Connect Options
Advanced connection options, accessed by clicking the Advanced button in the <Connect 
To> dialog, are available when you connect.    The options on the right hand side of this 
dialog (General options and Transaction Logging) can also be changed during    your session 
by choosing the Connection Settings command from the Options menu.
The <Advanced Connect Information> dialog options are listed below.    Click on the option 
for which you want help.
Note that changing these connection options upon login will only affect the session you are 
currently connecting to; if you want to save these options, you can save them to a 
connection.  Alternately, you can use the Default Connect Information command to set 
these options for all of your sessions. 

Advanced Login Options

Port
Show Login Greeting

Initialize Commands

Initial Directory

Firewall Options

Use Firewall

Type

Address

User ID

Password

Port

General Options

Timeout if no response after:

Poke host to avoid inactivity disconnect

Passive Data Transfers

File Transfer Mode

File List Format

Transaction Logging Options

Logging your Session

Log to File



Port
You can specify the FTP port you want to connect to.    In most cases, the default port, 21, will
work.    Change this value only if you know that you need to connect to a different port on 
the FTP host.



Show Login Greeting
NFM normally displays greeting information from the host you are connecting to.    Greeting 
information usually identifies the host and sometimes provides additional information about 
the host such as accessible hours, user limits, etc.    The greeting information is displayed in 
a separate dialog; you can scroll through the greeting using the scroll bars, when displayed.
You can turn off the display of the greeting by unchecking this option.
Note: Greeting information is not normally shown when reconnecting to a host using the Reconnect on Startup 

option.    You can, however, choose to display the greeting during a reconnection by unchecking Don't Show
Login Greeting in the <Startup Options> dialog.



Initialize Commands
NFM allows you to pass a number of FTP protocol commands directly to the FTP server 
immediately after login.    This option is provided to allow you to pass commands to servers 
that require special setup.    This is an advanced option; you should only use this if you are 
familiar with ftp protocol commands or are specifically instructed that you need to send 
special initialization commands when connecting to an FTP host.    You can use any FTP 
protocol commands in this field except for data transfer commands (RETR, STOR, LIST, 
NLST).    Internet RFC (Request For Comments) 959 (5.3.1-5.3.2) describes FTP protocol 
commands and command syntax.
Note: For example: some AS/400 ftp servers time out very quickly, and allow you to set a different time-out value 

using a TIME command.    If this was the case for a server you were connecting to, you might type TIME 
60000    in this field to set the timeout value higher.

You can provide several commands in this field, separated by commas (spaces after the 
commas are optional).



Initial Directory
You can specify the initial directory you want to connect to once you connect to the FTP 
server.    You can use this option to quickly connect to a directory on the FTP server.    NFM 
also allows you the option of automatically reconnecting to the last directory you were in, 
using the Reconnect option; see NFM Startup Options for more information.



Use Firewall
Some networks are protected by Internet firewalls.    Firewalls secure networks against 
outside access by requiring all information to and from outside networks to go through the 
firewall.    If your network uses a firewall, you must set up NFM so that it uses that firewall 
before you will be able to successfully use NFM.    Currently, only ANS firewalls are supported
by NFM, so you do not have to change the firewall type.
You set up NFM to use the firewall by setting up the firewall address and your user ID and 
password on that firewall.    You may also have to specify a firewall port.    Your network 
administrator should be able to supply this information.



Firewall Type
The type of firewall you are connecting to.    Currently, only ANS firewalls are supported, so 
you should not change this option.



Firewall Address
The IP address of the machine that has the firewall on it (specifically, the FTP Proxy portion 
of the firewall; some firewalls span multiple machines).    This will typically be a numeric IP 
address like 165.121.6.8.



Firewall User ID
Your user ID on the firewall.    This will be a unique ID on that firewall, assigned by your 
network administrator, that you are required to use to connect to the firewall.



Firewall Password
Your password on the firewall.    This is the password associated with your User ID, also 
assigned by your network administrator.



Firewall Port
The port to connect to on the firewall.    For FTP, this is usually 21.    Change this option only if
specifically instructed to by your network administrator.



Timeout if no response after __ seconds
This option controls how long NFM waits for response from the FTP server before assuming 
that the connection has been lost.    This option affects the initial connection to the host, 
reading in a new directory, or trying to transfer a file.    If the FTP server does not respond 
within the timeout value you specify, NFM will stop trying and will display a disconnect 
message.    The default of 30 seconds should work for most cases; if the FTP server you are 
connecting to takes a long time to respond, you may want to increase this value so that NFM
waits longer for a response before timing out.
This value must be at least 20 seconds, and can be as high as 999 seconds.    



Poke host every __ minutes to avoid inactivity disconnect
FTP hosts will disconnect from NFM after a certain period of time if you are not performing 
any activity on that host (listing directories, transferring files, etc.).    Fortunately, NFM does 
not close when disconnected, and if you try to continue to work on that FTP server you will 
simply be informed that you were disconnected and asked if you want to reconnect.
You may, however, prefer not ever to be disconnected when working; you can set this value 
in NFM order to trick the remote server into believing that you are active on the host, even 
when you are not using NFM.
You can set this value between 1-99 minutes.    Setting the value to 1 minute will help keep 
you from being disconnected inadvertently; the effect of    values will vary depending on the 
FTP server you are connected to.



Passive Data Transfers
The FTP protocol which NFM uses to present remote file systems normally uses the PORT 
command to establish data transfer channels.    If you need to get past Internet firewalls, or 
for some reason do not want to use the PORT command for data channel establishment, you 
can check this option to have NFM use the PASV command.



File Transfer Mode
When transferring files with NFM, you will need to choose between ASCII (text) and Binary 
(non-text files, such as executable files or graphic and sound files) methods of file transfer.    
Basically, if a file contains special control codes, (like a word processing document, graphics 
file, or a sound file) it should be transferred as Binary.    You can specify the default file 
transfer mode to use by choosing this option.    In most cases, you will probably want to 
leave this option as Binary, since you will probably mostly be transferring binary files.
You can easily change this option during an NFM session by clicking on the ASCII and 
Binary buttons on the NFM Toolbar.
Warning: If the wrong method is selected when you transfer a file, you may have 

problems.    Transferred ASCII files may not display properly if Binary mode is 
chosen, and transferred Binary files may not execute properly if transferred 
using ASCII mode.



File List Format
You can use this option to specify how you want NFM to display details about files.    By 
default, NFM displays files in Windows format;    in other words, it displays them in the same 
order they are listed in the Windows File Manager: name first, then size, date, time, etc.    
When you are accessing remote file systems, you may want to display them in the order 
they are displayed on that file system, e.g., the Native format.    For instance, UNIX hosts 
display file details in this order:    flags, links, owner, group, size, date, and name.    
Select Windows to display files in standard Windows order, with name first, then size, date, 
time, etc., or select Native to display files in the native file format of the remote system.



Logging your Session
You can have FTP log all of your session activity to a file or to the screen.    Logging your 
session activity may help you if you are having problems connecting to a host, accessing 
directories, or transferring files, by showing you the messages the host sends to NFM.
You can log three types of ftp transactions: FTP commands, FTP replies, and FTP file lists.    
FTP commands are commands sent to the host; when you ask to change directories or copy
files, etc.    
FTP replies are the acknowledgment of those commands, such as "File Copied 
Successfully".
FTP file lists are the file lists produced in response to an FTP LIST or NLIST command.    
These are the file lists you would typically see in a character based FTP session.    For 
instance, every time you change a directory, a new list of files is passed to NFM so that NFM 
can display the new directory on your screen.
Check which of these options you want to log.    By default, all three types of transactions are
logged.    If you check any of these options, your session will automatically be logged to a 
window.    Each directory window in NFM has a window pane, which is initially hidden, where 
the session will be logged.
To display the logging pane, move your cursor to the thin border between your NFM 
directory window and the NFM Status Bar (if you are not displaying your Status Bar, it will be
a border right on the bottom of your screen).    Your cursor will turn into a double headed 
arrow that you can push up to display the logging pane, (if you need more space to view 
logging activity, maximize your NFM Console by clicking the Maximize arrow in the upper 
right hand corner of the Console.)    Adjust the logging pane until you can view the session 
activity. 
The Clear Log command in the Window menu will clear all logging pane contents at any 
time. 



Log to File
If you want to save session activity permanently, or if you are having trouble connecting to a
host and want to view the log, you should log your session to a file.    Check the Log to File 
box to have NFM log to a file.
Normally, the log file that is used is ftp.log in the \...\BIN directory of your installation.    If 
you are using an NFM Connection to connect to the FTP server, the log file will be renamed 
to a unique name for you.    You can, however, specify any name (and location) you would 
like for this file.    You can specify a new name for this file by typing it in the provided field; it 
will be created.    Also, you can click the Browse button and specify a directory and filename
to use for the log file (again, if you specify a new filename in the Browse dialog, it will be 
created).
All your session activity will be written to the file that you specified.    This file is overwritten 
each time you start a new session.    If you want to save your last session log, change the 
name of the log file you are using, and exit and restart NFM.      
You can read a log file using a text editor like Windows Notepad.



Opening Multiple NFM Sessions
Once youve opened an NFM session, you can continue to open other NFM sessions.    Choose
New Connection from the Window menu or click the Connect button on the Toolbar.    You 
will see the <Connect To> dialog, and can log in to another session. 
If you have several NFM sessions open, you can change the way the session windows are 
displayed.    The Cascade command in the Window menu will cascade all open NFM 
windows (windows are stacked on top of one another), and the Tile command in the 
Window menu will automatically tile all open NFM windows (windows are displayed side by 
side).
You can also minimize NFM sessions by choosing Minimize from the Microsoft Windows 
System Menu, and specify Arrange Icons to arrange any minimized NFM icons so that 
they are evenly spaced and do not overlap.



Closing NFM Sessions and Exiting NFM
You can close all of your NFM sessions and keep NFM open; note that many menu options 
and dialogs will be unavailable when you are not connected to a host.
You can completely exit the Network File Manager by choosing Exit from the File menu or 
by double-clicking the Windows System menu in the upper left hand corner of the NFM 
Console.    This will close all open NFM sessions.



The NFM Console
When you first open NFM, the Network File Manager and Windows File Manager will be 
opened "tiled" (displayed on the screen) with the Network File Manager on top, and the 
Windows File Manager on the bottom.
You can tile the two windows horizontally (Windows File Manager on top, NFM on bottom) by 
choosing Tile FM and NFM Horizontally in the Window menu (or by pressing F6) or tile 
the Windows File Manager and NFM vertically (on top of one another) by choosing Tile FM 
and NFM Vertically in the Window menu (or pressing Alt-F6).
If you do not want to open the Windows File Manager automatically, you can uncheck Start 
File Manager at Startup in the <Startup Options> dialog, accessed by choosing Startup 
in the Options menu. 
The Status Bar at the bottom of the NFM Console displays information on the current status
of NFM operations, like connecting to a host or copying a file.    The Toolbar at the top of the
NFM Console has buttons displaying frequently used commands. You can see the meaning of
a Toolbar button by moving your mouse on top of it; the Status Bar will display the function 
of the button.    You can display the Toolbar as Picture only, Text only, or Both Picture and 
Text, by choosing Toolbar Style in the Options menu.    
Both the Toolbar and the Status Bar can be hidden by unchecking Show Toolbar and Show 
Status Bar in the Options menu.    The Toolbar and Status Bar will be displayed if checked.
You can also change the font that is used in the NFM Console by choosing Font in the 
Options menu.    A Windows font dialog box will appear; select the font you want to use, and
click OK.



Startup Options
The <Startup Options> dialog lets you specify whether connections will automatically be 
restored when you start NFM, and whether the Windows File Manager will automatically 
start when you start NFM.    Click on the option for which you want information.
Restore Connections at Startup 
Start File Manager at Startup 



Restore Connections at Startup
You can set up NFM to automatically try to restore any connections that were open the last 
time you used NFM, by using the <Startup Options> dialog, obtained by choosing Startup 
in the Options menu.    Selecting the Restore Connections at Startup option will cause NFM   
to try to open all of your currently open network connections. 
By default, you will be prompted with a <Reconnect To> dialog for each connection that NFM
tries to reopen.    To reconnect to that session, click OK.    You can, if you choose, ignore the 
reconnection and choose another FTP Server to connect to, or choose Cancel to decline the 
reconnection.    If you Cancel, you will be presented with the standard <Connect To> dialog.
However, you can choose to disable this login prompt, so that NFM transparently reconnects 
to all of the current network connections the next time you start NFM, without requiring you 
to login to each session.    You do this by unchecking the Confirm Reconnections option.    If 
this option is unchecked, the connections will be restored automatically.    (This option can 
also be set using the <Confirmation> dialog).    You can also check Restore Current Directory
to automatically display the directory you have current when the session is restored (as 
opposed to the home directory on that host).
The Don't Show Login Greeting option controls whether greeting information from the host is
displayed when reconnecting to that host.    Since you saw the login greeting when initially 
connecting to the host, this option is turned on by default.



Start File Manager at Startup
If you check Start File Manager at Startup in the <Startup Options> dialog, or in the 
Options menu, the Windows File Manager will automatically start when you start NFM.    If 
you uncheck this option, only NFM will be started. If the File Manager is started with this 
option, it will close when you exit NFM.    
You can tile the two windows horizontally (Windows File Manager on top, NFM on bottom) by 
choosing Tile FM and NFM Horizontally in the Window menu (or by pressing F6) or tile 
the Windows File Manager and NFM vertically (on top of one another) by choosing Tile FM 
and NFM Vertically in the Window menu (or pressing Alt-F6).



Working with Files in NFM
Once the Network File Manager is open and connected to a remote host, you can begin 
copying or moving files between your PC and that remote host, or between two remote 
hosts.    You can also perform other file operations like creating directories and renaming and 
deleting files or directories.    This section explains basic file operations in NFM.
Warning! You can only perform file operations that you have rights to perform, or that the 

FTP server you are connected to supports.    Some systems will not allow you to 
move files or create directories.    (On anonymous FTP Servers, you will typically 
only have rights to copy files from that server to your PC).

Operations in the Network File Manager are very similar to operations in the Windows File 
Manager:

You can view the files or directories inside a directory by double-clicking on the directory folder.    
You can also choose Open from the File menu to open a directory folder.

To move up to the previous directory level, click on the up arrow at the top of the directory list.

You can change directories by double-clicking on directory folders, just as you would when using 
the File Manager.    Some host systems do not support changing directories with a mouse.    In 
these cases, you can use the Change Directory command in the File menu to specify the name 
of the directory you want to change to.    This is also a quick way to change directories if you know
the full pathname of the directory you want.    The next section explains how to specify remote 
host files and directories in this and other NFM dialogs.

See
Selecting Files/Directories
Copying and Moving Files Using Drag and Drop 
Viewing and Printing Files
Renaming a file/directory
Creating a Directory 
Changing Directories
Deleting files/directories 
Confirming File Operations



Selecting Files and Directories
There are two ways to select files and directories for operations in NFM; you can specify 
them by filename, or you can select them using your mouse.    These two methods are 
described below.

Selecting files and directories by filename:

Specifying file and directory names for a remote host is very similar to specifying file and 
directory names on your local PC.    
Files and directories on a host are denoted in NFM by a hostname, followed by a colon and 
the path name syntax of the host system.    For instance, a UNIX file from host 
bart.marge.com would be displayed in a NFM dialog box as: 
bart.marge.com:/home/files/myfile.txt
Note that UNIX files use the forward slash instead of the backslash to denote subdirectories.
A DOS file is specified in the dialog with standard DOS filename syntax:
c:\files\filename.ext
The hostname used is based on the name or address you provided when you started the 
NFM session.
Warning: For the above reason, it is important not to name any of your hosts with a one 

character name, a-z, as these may also correspond to DOS drive letters, and 
NFM could not then distinguish them from DOS drives.

Selecting files and directories with your mouse:

You can select a file or directory to operate on by clicking on the file or directory name with 
your mouse.    You can also select multiple files by clicking on them with your mouse while 
holding down the    [Ctrl] or [Shift] keys.    [Shift] selects a series of adjacent files, while [Ctrl] 
allows you to individually select a number of non-adjacent files.
When the files/directories are selected, you can then use File menu operations on them, or 
drag and drop them onto a remote host or your local PC (via Windows File Manager).    See 
Copying and Moving Files with NFM, for more information.
Note: When filling out the file operation dialogs, the Current Directory (the currently selected or highlighted 

directory in NFM) is shown at the top of the dialog.    If you do not specify a pathname for any files you are 
manipulating, their origins or destinations will be assumed to be the currently selected directory.    To simplify 
operations, select the file or directory you want to operate on before choosing an NFM command.



Copying and Moving Files with NFM
The Network File Manager supports copying and moving files:

From your PC to an NFM host.

From an NFM host to your PC.

From one NFM host to another NFM host.

You can copy and move files either by dragging and dropping them or by using the File 
menu Copy or Move commands and specifying the file names and locations.

NFM does not permit you to copy or move entire directories.

You may want to customize your method of file transfer to the task you have to do.    Drag 
and drop is useful for moving many adjacent files or selecting files with nothing in common.
It also permits you to move files without having to know the entire file pathname.    Using 
Copy and Move from the File menu is useful when you want to specify a group of files with 
similar names (using wildcard techniques), all of the files in a large directory, or when you 
want to copy or move files that arent currently displayed on your screen.
Click on the topic below for which you want help.
____
See
Setting the File Transfer Method 
Filename Translation
Copy/Move Files Using Drag and Drop 
Copy/Move Files Using the File Menu 



Setting the File Transfer Method
You should make sure that the correct file transfer method is set before transferring files 
with NFM.    You can transfer files using Binary or ASCII file transfer.    You should use ASCII 
when transferring ASCII text files (like files produced with Windows Notepad), and Binary 
when transferring binary files (non-text files, such as executable files, graphics files, or 
sound files).    If a file contains special control codes, (like a word processing document, 
graphics file, or a sound file) it should be transferred as Binary.    You can specify the default
file transfer mode to use by choosing this option.    In most cases, you will probably want to 
leave this option as Binary, since you will probably mostly be transferring binary files.
You can easily change this option during an NFM session by clicking on the ASCII and 
Binary buttons on the NFM Toolbar.
Click the Binary or ASCII button on the Toolbar before transferring files. 
Hint: Since it is sometimes difficult to know before you transfer files what file transfer method to use, 

you may want to select Binary for most file transfers, and choose to examine text files using the 
Open command.    See Displaying and Printing Remote Host Files for more information.



Filename Translation
You can specify whether files that are transferred are automatically renamed by NFM.    
Often, remote files have names longer than DOS allows (DOS allows up to eight characters 
with a three character extension).    A long file name (example:    tcp.ip.intro.txt) is 
automatically translated by NFM into a legal DOS filename by using up to eight characters of
the filename, and adding an extension, if one was provided.    (In the example, the file would 
become tcpipint.txt.)
Check Confirm Filename Translation in the <Confirmation> dialog to set NFM to always 
prompt you before it translates a filename (using the method above).
When this option is checked on, and you copy or move one or more files with long filenames,
you will see a <Confirm Filename Translation> dialog.
This dialog suggests a default filename for a file with a long filename.    Select Yes to accept 
the provided filename, or    change the filename to one you prefer before selecting Yes.    
Select No if you do not want to copy or move the file at the current time.    If you are copying
or moving several files, you will be prompted to accept filenames for each filename; you can
select Yes to All to accept the default filenames for all long files in your copy/move 
transaction.    Cancel will cancel the current file transfer or any file transfers in the batch.



Copy/Move Using Drag and Drop
"Dragging" is done by clicking on the file name (or group of file names) you want to copy or 
move and holding down the mouse button while you move the mouse, thereby dragging the 
file or directory with you.    You can drag/copy (drag a copy of the selected file(s) by simply 
dragging the file(s) ([Ctrl]-drag will also copy files).    You can drag/move (removing the 
original file(s)) by holding down [Shift] as you drag the file(s).
You then "drop" the file(s) by releasing the mouse button at the place that you want to copy 
the file(s).    The file(s) will then be copied or moved, as simple as that.

Drag and Drop from your PC to an NFM host

You can drag and drop files from your PC to a NFM host by dragging them from the Windows 
File Manager to the directory where you want to keep them on the host.
To copy/move files, select the file(s) you want to copy or move in the Windows File 
Manager, drag them to an NFM directory window, and drop them onto the area where you 
want to move them.    (You can only copy files to an NFM host if you have permission to do so
on that host).    Moving files from the Windows File Manager to NFM using drag and drop is 
not supported (due to Windows File Manager's operation).

Drag and Drop from a NFM host to your PC or other NFM host

You can copy or move files from a NFM host to your PC or another NFM host by selecting 
the file(s) on your NFM Directory window, dragging the file(s) you selected to your Windows 
File Manager screen or to another NFM directory window, and dropping them onto the area
where you want to move them.    (You can only move files from an NFM host if you have 
permission to do so on that host).



Copy/Move Files Using the File Menu
You can copy or move files using the Copy or Move commands in the NFM File menu.
You can copy or move files from a NFM host to your PC or another NFM host, or from your PC 
to an NFM host.    You do this by typing the file origin and destination in the Copy or Move 
dialogs.
To save time, first use the mouse to select the files you want to transfer.
Then choose Copy or Move in the File menu.
The specified files will be copied or moved.



NFM Filename Syntax
Files/directories on a NFM host are specified by a hostname, followed by a colon.    They 
then use the pathname syntax of the host system.    For instance, a UNIX file from host bart 
would be displayed in a NFM dialog box as: 
bart:/home/files/myfile.txt
where host is the name of the host you are connected to;
and /home/files/myfile.txt is the path and filename of the file in that host's format.
Files on your PC can be specified as follows:
c:\files\myfile.txt
The copy and move command dialog box supports the use of file wildcards, (? and *), which 
allow you to substitute for characters that you do not know (or wish to type).    For instance, 
you could copy files from sunhost:/home/files/data??? or from c:\files\*.txt.



Viewing and Printing Files
Once you have connected to a host, you may be able to directly view or print files with 
Network File Manager.    NFM recognizes files just like the Windows File Manager does, by 
examining the files extension and checking to see what application is associated with that 
type of file.    For instance, the file hello.txt has extension txt, which is associated by 
Network File Manager with the Windows Notepad application.    So, when you try to view or 
print this file in Network File Manager using the Open or Print commands, the file will 
automatically be opened/printed using Windows Notepad.
____
See
Using File Associations
Viewing Files
Printing Files



Using File Associations
File associations in NFM work just the way they do in the Windows File Manager.    You use an 
Associate command to tell NFM how to recognize and open associations, so that you can 
open or print a file directly from NFM.
NFM automatically uses any associations that were set up in Windows File Manager; you can 
then examine and change those associations and add additional associations.
You can add a new association at any time.    You may find it convenient to add associations 
when you are highlighting a filename that you want to associate.
Click Associate from the File menu.      An <Associate> dialog will appear, showing a list of 
file associations.    If you currently have a file highlighted, any association for that file will 
display.
You can create a new association, or change an existing association by typing the extension 
you want to associate into the Files with Extension field (if you highlighted a file, it will 
already be there).
You can then choose the application to associate this extension with from the Associate With
drop-down list.    If the application is not in the list, you can use the Browse button to locate 
the application on your PC.
Note: NFM allows you to define an association for files with no extension.    You can do this by specifying . (period) 

in the Files with Extension as the extension (in other words, specifying no extension), and choosing the 
application to associate with those files.    For instance, if you often find readme files with no extension, you 
might associate . with Microsoft Windows Notepad, so that these files are opened correctly.    NFM also uses
this "default" extension whenever it encounters files with non-standard extensions (e.g. 
bar_association.news), so this is a handy feature to use.    Use this feature with care, though, since there is
often no way to tell which application to use to open a file when it has a non-standard extension.

Because you are transferring the files (into your system memory) before you open or print 
them, you may need to specify the file transfer type for each file association.    For text files, 
make sure that the Open File As value is set to ASCII to ensure that they will open correctly;
for any other files (including word processing documents), you will probably want to set this 
value to Binary.    For more information, see the previous section on Setting the File Transfer 
Method.
Click OK when you have finished making associations.



Viewing Files
You can open a file on a remote host by double-clicking on it, selecting the file and pressing 
Enter, or choosing Open from the File menu. If there is an association set up for that file,     
NFM will launch the program associated with that file and display the file. (If there is no 
association for that file, NFM will display a message informing you that there is no 
association for that file).
If the file does not have an extension that you can associate with an application, you will 
have to transfer the file to your PC before you can open it in an application.
You can check the Minimize on File Open command if you wish to automatically minimize 
the Network File Manager Console when any NFM files are opened.



Renaming a File/Directory
You can rename a file or directory by highlighting the file or directory you want to rename, 
and clicking Rename in the File menu.    You will be prompted for a new filename or 
directory name.    Type the name, and click OK.
You can also specify the original and new names for the file/directory in the dialog without 
highlighting them first.



Deleting Files/Directories
To delete files/directories, select them using the mouse and choose Delete from the File 
menu or press the Delete key on your keyboard.    (You can also specify the file/directory 
name(s) in this dialog).    Click OK to delete the files/directories.



Confirming File Operations
When you copy or move files, or delete or replace files on the host, you will automatically be
prompted to confirm that you want to perform those actions.    You can enable or disable this 
confirmation step using the <Confirmation> dialog in the Options menu.
In this dialog, you can also specify whether to confirm mouse actions (any drag and drop 
activity), whether to confirm automatic reconnection to a host, and whether to ask for 
confirmation when translating a long filename during file transfer.



Displaying Files in NFM
When you display files and directories on a remote host, they appear in a directory window.   
Files will be displayed as documents, and directories will be displayed as folders, similar to 
the Microsoft Windows File Manager. 
There are several ways to change how files are displayed in the Network File Manager. You 
can specify the following options:

Which file details are listed.

The order in which files are listed.

Which files are listed.

These options will be set for the current session only.
The methods used to change these settings are described below:

Setting which file details are listed:

You can change which of the file details (such as Name, Date, Size, Owner, etc.) are listed by
choosing All File Details, or Partial Details options in the NFM View menu, as described 
below.
All File Details Displays all available file details for files 

on the host you are connected to.    These details will vary according to 
the host.

Partial File Details Allows you to specify which file details you want to display.    Check the 
details that you want to display, and click OK.    (You can also select this 
item by clicking on the Details button on the Toolbar.)

You can change the size of the Name field by moving your cursor to the separator to the right of the Name 
field until it turns into a double headed arrow, holding down your mouse button, and moving it left or right to 
change the size of the field.    Note:    this will not apply if you are in host directory list format, or if you are 
using the Generic host driver to connect to hosts.

Setting the order in which files are listed:

NFM allows you to change how NFM sorts the files in the listing by clicking on the detail 
header for that detail.
You can also sort by choosing the Sort by... options in the Options menu.    
The sorting is done by the methods described below.
Sort by Name
List files in alphabetical order (this is the default).
Sort by Type
List files in alphabetical order by their extensions (e.g. link.dll, test.dll, auto.exe, timer.exe, 
story.txt).
Sort by Size, Date, Owner, Group, Etc.
Other sorting options will appear in this menu based on the available file details of the host 
that you are connecting to.    Sort by size will list files from smallest to largest, sort by date 
from oldest to newest.

Setting which files are listed:



You can also select which files are listed using By File Type in the View menu.    
By File Type...
This dialog allows you to specify whether directories, programs, documents, or other files 
(non-directories, programs, and documents) are listed.
You can also list files with any given file specification by typing the specification using a 
wildcard combination (*, ?) in the provided dialog box.    To select all files, leave this box 
blank.
Note: If you use wildcards, you must use the wildcard conventions used on the file system you are viewing.    For 

instance, on a UNIX system, specifying *.txt would list only files with the extension txt, and specifying doc* 
would list only files that begin with the first three letters doc are listed.



Saving Your NFM Settings
NFM will save your current workspace and settings when you exit if you have checked Save 
Workspace on Exit in the Options menu.      Whenever NFM starts, it restores the 
workspace to the last workspace that was saved.    This includes reestablishing all 
connections, if you have the Restore Connections on Startup option (set using the 
Startup option in the Options menu).
The types of settings that will be saved are:

Startup settings (whether to open File Manager on Startup, whether to automatically reconnect to 
the host)

Console Settings (whether to display the Toolbar and Status Bar, the Toolbar type, the position 
and size of the NFM and File Manager windows).

All your connection settings, including the layout (size and position) of NFMs work area, and all 
connection related settings such as the file listing options in the View menu.

Changes to the Associations and the Connection list are saved automatically, regardless of 
the Save Workspace setting.



NFM Menu Commands
The NFM menu commands are described below.
File menu 
View menu 
Options menu 
Window menu 



File menu
Open
Move
Copy
Delete
Rename 
Properties 
Quick Properties 
Print 
Associate 
Create Directory 
Change Directory 
Edit Connection List
Exit 



Open
The Open command will open the currently selected file into an associated application, if 
one exists.    This command will not work on a file if you have not set file associations for files
with that file extension.    See file associations for more information.    
If you choose the Open command with a directory folder selected, the directory folder will 
be opened, and any files/directories inside that folder will be displayed.



Move
When you choose the Move command, any files you selected will be specified in the From: 
(origin) field.
Specify the origin (From:) and destination (To:) filenames in the appropriate filename syntax.
Note: If you provide no host designation or pathname, NFM will assume the files you are specifying are found in 

the current directory on the current host (the host directory window that is currently highlighted).    This 
means that there is an advantage to selecting your origin directory before beginning a file operation, to 
eliminate having to type a long pathname.

Click OK.    The specified file(s) will be moved    (the original file(s) will be removed from the 
PC or host).    



Copy
When you choose the Copy command, any files you selected will be specified in the From: 
(origin) field.
Specify the origin (From:) and destination (To:) filenames in the appropriate filename syntax.
Note: If you provide no host designation or pathname, NFM will assume the files you are specifying are found in 

the current directory on the current host (the host directory window that is currently highlighted).    This 
means that there is an advantage to selecting your origin directory before beginning a file operation, to 
eliminate having to type a long pathname.

Click OK.    The specified file(s) will be copied.    



Delete
The Delete command deletes the currently selected file(s) or directories.
To delete files/directories, select those files/directories using the mouse and choose Delete 
from the File menu.    (You can also specify the file/directory name(s) in this dialog).    Click 
OK to delete the files/directories.
You can also delete files by clicking the Delete key on your keyboard.



Rename
The Rename command renames a file or directory.
You can rename a file or directory by highlighting the file or directory you want to rename, 
and clicking Rename in the File menu.    You will be prompted for a new filename or 
directory name.    Type the name, and click OK.
You can also specify the original and new names for the file/directory in the dialog without 
highlighting them first.



Viewing File Information: Properties/Quick Properties
NFM allows you to view file information from the host using the Properties and Quick 
Properties commands.    The information that will be displayed is virtually the same 
information you will see if you are connecting to the host with the correct host driver and are
displaying all the file details; therefore this feature is only really helpful if you are currently 
using the Generic host driver, or if you need additional information about a file.
Properties will display all available information about the file in a dialog.
Highlight the file name, and choose Properties from the File menu.    A dialog will appear, 
displaying all available information from the host.    You can scroll through the dialog to read 
all the information.    Click OK to close the dialog.
Quick Properties will summarize the information about the file in the NFM Status Bar.
Highlight the file name and choose Quick Properties from the File menu (or press Ctrl-
Alt-Enter).    The Quick Properties information will appear in the Status Bar, and will stay 
there until you highlight another file.
Properties and Quick Properties work only for files; highlighting a directory name will 
indicate that the highlighted item is a directory.



Print
The Print command in the File menu prints the currently selected file.    Before using this 
command, you should use the NFM Associate command to properly set file associations.    
NFM will launch the program associated with that file and display the print dialog from that 
program.    You can then print the file.



Associate
File associations in NFM work just the way they do in the Windows File Manager.    You use the
Associate command, found in the File menu, to tell NFM how to recognize and open 
associations, so that you can open or print a file directly from NFM.    NFM automatically uses
any associations that were set up in Windows File Manager; you can then examine and 
change those associations and add additional associations.
You can add a new association at any time.    You may find it convenient to add associations 
when you are highlighting a filename that you want to associate.
When you open the <Associate> dialog, you will see a list of file associations.    If you 
currently have a file highlighted, any association for that file will display.
You can create a new association, or change an existing association by typing the extension 
you want to associate into the Files with Extension field (if you highlighted a file, it will 
already be there).
You can then choose the application to associate this extension with from the Associate With
drop-down list.    If the application is not in the list, you can use the Browse button to locate 
the application on your PC.
Because you are, in fact, transferring the files (into your system memory) before you open 
or print them, you may need to specify the file transfer type for each file association.    For 
text files, make sure that the association was set to ASCII to ensure that they will open 
correctly; for any other files (including word processing documents), you will probably want 
to specify Binary.
Click OK when you have finished making associations.



Create Directory
The Create Directory command in the File menu (also found as a button on the Toolbar) 
creates a directory on the current host.
You can create a directory at any time by using this option.    You may find it easier to first 
select the location where you want a directory before choosing the create option.    
The <Create Directory> dialog will ask you to specify a new directory name.    Specify a 
name for the new directory, and click OK to create the directory.
Note: You must have rights on the FTP host in order to create a directory.



Changing Directories
The Change Directory command in the File menu lets you change directories on the host 
using a dialog, rather than by clicking with your mouse.    This is a quick way to change 
directories if you are familiar with the structure of the host you are connecting to; some 
hosts may only allow you to change directories using this command (depending on their 
structure).
See NFM Filename Syntax for more information on specifying filenames in NFM.



Edit Connection List
The <Edit Connection List> dialog, produced by choosing Edit Connection List from the 
File menu, allows you to view all the Connections you created, create new Connections, and
edit information about those connections.
Note: Hosts in your Hosts file will not display in this list.

From this dialog, you can:
> Add a new Connection by clicking the New button.    The <New Connection> dialog will appear.    

You can fill out this dialog with information about your new Connection.

> Edit an existing Connection by highlighting a connection name and clicking the Edit button.    The 
<Edit Connection> dialog will appear, allowing you to change any of the information about your 
Connection.

> Delete a Connection by clicking the Delete button.    You will be asked to confirm that you want to 
delete the Connection, and the Connection will then be deleted.



Defining a New Connection
The <New Connection> dialog allows you to create a new Connection.    This is equivalent to 
creating a Connection using the <Connect To> dialog.
This dialog asks you to specify a name for the connection, and asks you to specify the same 
information that is found in the <Connect To> dialog; the advanced connection options from 
the <Connect To> dialog can also be accessed by clicking the Advanced button.
Fill out these options as you would when making a connection.
Click OK when you are finished creating this Connection; this Connection will be added to 
your Connection list.



Edit Connection
The <Edit Connection> dialog allows you to change any of the specified information for a 
Connection.    This dialog displays the same information that is found in the <Connect To> 
dialog; the advanced connection options from the <Connect To> dialog can also be 
accessed by clicking the Advanced button.
Click OK when you are finished editing the Connection; the Connection will be changed as 
you specified.



View menu
All File Details 
Partial Details 
Sort by Name, Type, Size, Date, Etc. 
By File Type



All File Details
This command displays all available file details (such as filename, date, size, etc.) for files on
the host you are connected to.    These details will vary according to the host.



Partial Details
This allows you to specify which host file details (such as filename, date, size, etc.) you want 
to display.    In the <Partial Details> dialog, check the details that you want NFM to display.    
You can also select Partial Details by clicking on the Details button.



Sort by Name, Type, Size, Date, Etc.
Sort by Name
List files in alphabetical order (this is the default).
Sort by Type
List files in alphabetical order by their extensions (i.e. link.dll, test.dll, auto.exe, timer.exe, 
story.txt).
Sort by Size, Date, Owner, Group, Etc.
Other sorting options will appear in the View menu based on the available file attributes of 
the host you are connecting to.    Sort by size will list files from smallest to largest, sort by 
date from oldest to newest.



By File Type
This allows you to specify what file types will be listed in the directory window. 
You can specify whether directories, programs, documents, or other files (non-directories, 
programs, and documents) are listed.    These are determined by file extension.
You can also list files with any given file specification by typing the specification using a 
wildcard combination (*, ?) in the provided dialog box.    To select all files, leave this box 
blank.
Note: If you use wildcards, you must use the wildcard conventions used on the file system you are viewing.    For 

instance, on a UNIX system, specifying *.txt would list only files with the extension txt, and specifying doc* 
would list only files that begin with the first three letters doc are listed.



Options menu
Default Connect Information
Connection Settings
Confirmation 
Startup 
Font 
Toolbar Style
Show Toolbar/Status Bar
Resolve Files of Unknown Type 
Minimize on File Open 
Save Workspace on Exit 



Default Connect Information
You can have NFM automatically fill out all of the options you specify upon connecting to a 
host, so that these options are always assumed.    For instance, if you often login to 
anonymous ftp sites, you may want to have NFM always specify user name of anonymous 
with a password of your user name.    Any information you specify in the <Default Connect 
Information> dialog will always display when you connect to a host (although you can 
change it, if you need to).
The <Default Connect Information> dialog is produced by selecting Default Connect 
Information from the Options menu.    This dialog is filled out exactly as you would fill out 
the <Connect To> dialog.
Fill out any information you want to have display in the <Connect To> dialog. 
You can also click the Advanced button to specify default advanced connection options for 
NFM.    
The information you provide in these dialogs is also used by default when you add a new 
host using the Edit Connection List feature.



Default Advanced Connect Options
The <Default Advanced Connect Options> dialog (accessed by clicking the Advanced 
button in the <Default Connect Information> dialog) allows you to specify default advanced 
options for all of your NFM sessions.    These are the same options you will see in the 
<Advanced Connect Options> dialog.
For instance, if you need to use a firewall in order to use NFM, you would want the firewall 
information to be filled out automatically.    Fill out any information you want to have 
automatically appear in the Advanced portion of the <Connect To> dialog.



Connection Settings
The Connection Settings option allows you to change options for your current NFM 
session; these are the same options found on the right hand side of the <Advanced 
Connection Settings> dialog.    Click on the option below for which you would like help.

General Options

Timeout if no response after:

Poke host to avoid inactivity disconnect

Passive Data Transfers

File Transfer Mode

File List Format

Transaction Logging Options

Logging your Session

Log to File



Confirmation
The Confirmation command in the File menu lets you specify whether NFM will ask you for 
confirmation when performing the following actions: deleting a file/directory, replacing a file,
mouse actions (drag and drop), automatically reconnecting to a host, and translating long 
filenames.



Toolbar Style
The NFM Toolbar can be displayed with a Picture only, Text only, or Both Picture and 
Text, by choosing Toolbar Style in the Options menu.    Check the option in the dialog that
you want to display.



Font
You can change the font that is used in the Network File Manager by choosing Font in the 
Options menu.    A Windows font dialog box will appear; select the font you want to use, and
click OK.



Show Toolbar and Status Bar
The NFM Toolbar at the top of the NFM Console has buttons displaying frequently used 
commands. You can change the Toolbar Style, if desired.
The Status Bar at the bottom of the NFM Console displays information on the current status 
of NFM operations, like connecting to a host or copying a file.    
Both the Toolbar and the Status Bar can be hidden by unchecking Show Toolbar and Show 
Status Bar in the Options menu. 



Resolve Files of Unknown Type
If you are using the Generic host type when connecting to a host, NFM will typically only 
show you limited information about a host.    If you want NFM to try to resolve additional file 
details when displaying file information using the Generic host type, select the "Resolve Files
of Unknown Type" option from the Options menu to check this option.    Note that when using
this option, NFM will take slightly more time upon connection when encountering files of 
unknown type.



Minimize on File Open
If this is checked, the Network File Manager Console will be minimized if any of the files in 
the NFM directory windows are opened.



Save Workspace on Exit
General NFM settings (whether to open File Manager on Startup, displaying the Toolbar, etc.)
as well as settings used in a particular NFM directory window (view method, sort methods) 
can be saved by checking Save Workspace on Exit in the Options menu.      The general 
settings will be preserved the next time you open an NFM session, whereas particular 
directory window settings will only take effect the next time you open that directory 
window.



Window menu
New Connection
Cascade/Tile 
Arrange Icons 
Clear Log
Refresh 
Tile FM and NFM Vertically/Horizontally 



New Connection
You can open sessions to other NFM hosts once you have started NFM by choosing New 
Directory Window from the Window menu.    The NFM <Connect To> dialog will appear 
and you can specify the options for another NFM session.    The new session will open on top 
of the original session (use Cascade or Tile, or minimize a session window, to organize 
multiple directory windows).



Cascade/Tile
Cascade
Cascade all open NFM windows (windows are stacked on top of one another).
Tile
Tile all open NFM windows (windows are displayed side by side).



Arrange Icons
Arrange any minimized NFM icons so that they are evenly spaced and do not overlap.



Clear Log
The Clear Log command allows you to clear the contents of the NFM logging window pane.  
Any new transactions will appear in the cleared logging pane.
____
See
Logging your Session



Refresh
Update the active directory window with any recent changes (such as changes made at the 
host end).



Tile FM and NFM Vertically/Horizontally
You can open the Network File Manager and Windows File Manager "tiled" (displayed on the 
screen) with the Network File Manager on top, and the Windows File Manager on the bottom. 
You can tile the two windows horizontally (Windows File Manager on top, NFM on bottom) by 
choosing Tile FM and NFM Horizontally in the Window menu (or by pressing F6).
You can tile the Windows File Manager and NFM vertically (on top of one another) by 
choosing Tile FM and NFM Vertically in the Window menu (or pressing Alt-F6).
 




